• English
  • Hindi
  • Bahasa
  • Vietnemese
  • Malay
  • Thai
Show Sidebar

VMAX Unity Plugin for iOS – Alternative Method

Integrate the Plugin

For Xcode 7+

Note: The minimum iOS version supported is iOS 8.0. If you want to use Google AdMob or Millennial Media Mediations then the minimum base sdk (compilation sdk) iOS version should be iOS 9.0. However it will still work on iOS 8.0 & above devices.

Currently the VMAX SDK and all the Mediation Adapters does not support Bitcode in XCode 7 (iOS9). Hence if you are using XCode 7 then in Build Settings set “Enable Bitcode” setting to NO.


Set “Enable modules(C and Objective-C)” to YES.


Add -lxml2 and -ObjC to Linker Flags.


By default, iOS9 supports only HTTPS communication. To override this behaviour set the below dictionary in your application info.plist. Ignore if already added.

Supporting Unity 4

While adding adapters unity 4 will throw error for adapter code being ARC supported. We need to explicitly mention the compiler that these are ARC supported files. We can do this by setting “-fobc-arc” flag on the VMAX source, which is as follows

  1. Goto Build Phases -> Compile Sources and search for the String “VMax
  2. Select the all files under “Compile Sources” and set “Compiler Flags” as “-fobc-arc”


Read more on how to request ads.