VMAX
 
 
 
 
Show Sidebar

Integrating Mediation Partners – Android Unity

  1. To support Mediation with partners, integrate the VMAX library project. Currently, AdMob, AdColony, Facebook Audience Network, Flurry, Chartboost, Millennial Media, Tapjoy, Unity Ads, Bee7 and Vungle.
  2. Using the table below, delete the plugin files that you do not wish to integrate from Mediation and Support Libraries/Mediation.
  3. Copy the folder Mediation and Support Libraries/Mediation to Assets/Plugins/Android in your Unity project.
  4. For the mediation partners that you do not wish to use, remove the code as shown in the table below.

 

Partner Files to be deleted  Code to be removed from AndroidManifest.xml
Assets/Plugins/Android
folder
Adcolony adcolony.jar <Start Adcolony>…..
<End Adcolony>
Pokkt PokktSDK_v4.1.1.aar <Start Pokkt>…..
<End Pokkt>
Facebook AudienceNetwork.jar. From version 3.5.3 onwards of Vmax  refer “AudienceNetwork.aar” outside this mediation project <Start Facebook>…..
<End Facebook>
ChartBoost chartboost.jar Start Chartboost>…..
<End Chartboost>
AdMob Google Play service Library Project <Start Admob>…..
<End Admob>
Vungle
  1. vungle-publisher-adaptive-id-3.3.5.jar
  2. nineoldandroids-2.4.0.jar. Not required for Vungle 3.3.5 version onwrads.
  3. javax.inject-1.jar
  4. dagger-1.2.2.jar/dagger-2.1.jar(vungle 3.3.5 onwards)
<Start Vungle>…..
<End Vungle>
Flurry
  1. FlurryAnalytics-6.2.0.jar
  2. FlurryAds-6.2.0.jar
<Start Flurry>…..
<End Flurry>
Millennial Media MMSDK.jar <Start Millennial Media>…..
<End Millennial Media>
Tapjoy tapjoyconnectlibrary.jar <Start Tapjoy>…….

<End Tapjoy>

Unity Ads unity-ads (folder)/unity-ads.aar outisde mediation library project <Start UnityAds>….

<End UnityAds>

Bee7 bee7androidgamewall (folder)/bee7.aar outisde this mediation library project <Start Bee7>….

<End Bee7>

Note 1: Add the following attribute to the <Application> tag, to support video Ads with mediation partners like Vungle, AdColony, Chartboost, Unity Ads:

Note 2: All the mandatory permissions required by the partners are present in the Vserv Library project or vmax.aar. Do not add them again in your application manifest file.
Note 3: Use the latest version of the Google Play Service library to support all of its native functions.

Note 4: Vungle, AdMob , Millennial Media,Bee7 and Tapjoy require Google Play Service library to function.
Note 5 : Flurry, Vungle and Facebook require Android V4/ V7 support library.

Read more on Testing the Integration here.