Show Sidebar

VMAX Unity Plugin for iOS – Alternative Method

Sorry, this entry is only available in English. For the sake of viewer convenience, the content is shown below in the alternative language. You may click the link to switch the active language.

Integrate the Plugin

For Xcode 7+

Note: The minimum iOS version supported is iOS 8.0. If you want to use Google AdMob or Millennial Media Mediations then the minimum base sdk (compilation sdk) iOS version should be iOS 9.0. However it will still work on iOS 8.0 & above devices.

Currently the VMAX SDK and all the Mediation Adapters do not support Bitcode in Xcode 7 (iOS9). Hence if you are using Xcode 7 then in Build Settings set “Enable Bitcode” setting to NO.
image00
Set “Enable modules(C and Objective-C)” to YES.
image03
Add -lxml2 and -ObjC to Linker Flags.
image02

By default, iOS9 supports only HTTPS communication. To override this behaviour set the below dictionary in your application info.plist. Ignore if already added.

Files to be deleted from

Partner Files to be deleted from
Adapters Folder Adapters/Lib Folder Dependent Frameworks Other XCode settings
Adcolony VMaxAdColonyInterstitialAdapter.h

VMaxAdColonyInterstitialAdapter.m

AdColony.framework libz.1.2.5.dylib

AdColony.framework

AdSupport.framework

AudioToolbox.framework

AVFoundation.framework

CoreGraphics.framework

CoreMedia.framework

CoreTelephony.framework

EventKit.framework

EventKitUI.framework

MediaPlayer.framework

MessageUI.framework

QuartzCore.framework

Social.framework

StoreKit.framework

SystemConfiguration.framework

WebKit.framework

Enable Bitcode: NO.
Facebook VMaxFacebookBannerAdapter.h

VMaxFacebookInterstitialAdapter.h

VMaxFacebookNativeAdapter.h

VMaxFacebookBannerAdapter.m

VMaxFacebookInterstitialAdapter.m

VMaxFacebookNativeAdapter.m

FBAudienceNetwork.framework libz.1.2.5.dylib

AdSupport.framework

AudioToolbox.framework

AVFoundation.framework

CoreGraphics.framework

CoreMedia.framework

CoreTelephony.framework

EventKit.framework

EventKitUI.framework

MediaPlayer.framework

MessageUI.framework

QuartzCore.framework

Social.framework

StoreKit.framework

SystemConfiguration.framework

WebKit.framework

Enable Bitcode: NO.
ChartBoost VMaxChartBoostInterstitialAdapter.h

VMaxChartBoostInterstitialAdapter.m

Chartboost.framework Storekit.framework

Foundation.framework

CoreGraphics.framework

UIKit.framework

AdMob VMaxGoogleMobileAdsBannerAdapter.h

VMaxGoogleMobileAdsInterstitialAdapter.h

VMaxGoogleMobileAdsNativeAdapter.h

VMaxGoogleMobileAdsBannerAdapter.m

VMaxGoogleMobileAdsInterstitialAdapter.m

VMaxGoogleMobileAdsNativeAdapter.m

GoogleMobileAds.framework AdSupport.framework

AudioToolbox.framework

AVFoundation.framework

CoreGraphics.framework

CoreMedia.framework

CoreTelephony.framework

EventKit.framework

EventKitUI.framework

MessageUI.framework

StoreKit.framework

SystemConfiguration.framework

Linker Flags: -ObjC

Enable Bitcode: NO.

InMobi VMaxInmobiNativeAdapter.h
VMaxInmobiNativeAdapter.m
VMaxInmobiBannerAdapter.h
VMaxInmobiBannerAdapter.m
VMaxInmobiInterstitialAdapter.h
VMaxInmobiInterstitialAdapter.m
libInMobi-5.3.0.a

Headers

AdSupport.framework
AudioToolbox.framework
AVFoundation.framework
CoreLocation.framework
CoreTelephony.framework
CoreGraphics.framework
EventKit.framework
EventKitUI.framework
Foundation.framework
MediaPlayer.framework
MessageUI.framework
Security.framework
Social.framework
StoreKit.framework
SystemConfiguration.framework
UIKit.framework
SafariServices.framework
libsqlite3.0.tbd
libc++.tbd
libz.tbd
Linker Flags: -ObjC

Enable Bitcode: NO.

Vungle VMaxVungleInterstitialAdapter.h
VMaxVungleInterstitialAdapter.m
VungleSDK.embeddedframework AdSupport.framework
AudioToolbox.framework
AVFoundation.framework
CFNetwork.framework
CoreGraphics.framework
CoreMedia.framework
Foundation.framework
MediaPlayer.framework
QuartzCore.framework
StoreKit.framework
SystemConfiguration.framework
UIKit.framework
libz.dylib
libsqlite3.dylib
Enable Bitcode: NO.
Flurry VMaxFlurryBannerAdapter.h

VMaxFlurryInterstitialAdapter.h

VMaxFlurryInterstitialAdapter.m

Flurry

FlurryAds

AdSupport.framework
AVFoundation.framework
CoreGraphics.framework
CoreMedia.framework
Foundation.framework
MediaPlayer.framework
Security.framework
StoreKit.framework
SystemConfiguration.framework
UIKit.framework
libz.dylib
Enable Bitcode: NO.
Millennial Media VMaxMMediaBannerAdapter.h
VMaxMMediaInterstitialAdapter.h
VMaxMMediaBannerAdapter.m
VMaxMMediaInterstitialAdapter.m
MMAdSDK.framework AdSupport.framework
AudioToolbox.framework
AVFoundation.framework
CoreBluetooth.framework
CoreGraphics.framework
CoreLocation.framework
CoreTelephony.framework
EventKit.framework
EventKitUI.framework
Foundation.framework
libxml2.dylib
MediaPlayer.framework
MessageUI.framework
StoreKit.framework
SystemConfiguration.framework
UIKit.framework
Other linker Flags: -lxml2
Enable Bitcode: NO.
Unity Ads UnityAds.framework StoreKit.framework, AdSupport.framework and CoreTelephony.framework
Pokkt VMaxPokktRewardedVideoAdapter.h
VMaxPokktRewardedVideoAdapter.m
PokktSDK.framework
PokktSDK.bundle
ComScore.framework
CoreData.framework
Foundation.framework
MediaPlayer.framework
SystemConfiguration.framework
UIKit.framework
CoreTelephony.framework
EventKit.framework
AdSupport.framework
CoreGraphics.framework
Linker Flags: -ObjC
Enable Bitcode: NO
Tapjoy VMaxTapjoyRewardedAdapter.h
VMaxTapjoyRewardedAdapter.m
Tapjoy.embeddedframework AdSupport
CFNetwork
CoreData
CoreGraphics
CoreLocation (Optional for SDK 11.9.0 and higher)
CoreMotion
CoreTelephony (Can be marked Optional for compatibility with older iOS versions)
EventKitUI
EventKit
Foundation
libc++
libsqlite3.0
libxml2
libz
MapKit
MediaPlayer
MessageUI (Not needed for SDK 11.9.0 and higher)
MobileCoreServices
PassKit (Can be marked Optional for compatibility with older iOS versions)
QuartzCore
Security
Social (Can be marked Optional for compatibility with older iOS versions)
StoreKit (Can be marked Optional for compatibility with older iOS versions)
SystemConfiguration
Twitter
UIKit
Enable Bitcode: NO.

Supporting Unity 4

While adding adapters unity 4 will throw error for adapter code being ARC supported. We need to explicitly mention the compiler that these are ARC supported files. We can do this by setting “-fobjc-arc” flag on the VMAX source, which is as follows:

  1. Go to Build Phases > Compile Sources and search for the String “VMax”
  2. Select “All files” under “Compile Sources” and set “Compiler Flags” as “-fobjc-arc”

image08

Read more on how to request ads.