Show Sidebar

Millennial Media Integration using Android SDK

ขออภัยรายการนี้จะใช้ได้เฉพาะในภาษาอังกฤษ English. For the sake of viewer convenience, the content is shown below in the alternative language. You may click the link to switch the active language.

Current Millennial Media Version: 6.3.1

Supported Ad Formats: The VMAX SDK supports banner ads, interstitial ads , and interstitial video ads from Millennial Media.

You will need

  1. an active Millennial Media account
  2. Username
  3. Password
  4. App Tracking ID
  5. Ad Size

Prerequisite

MMSDK.initialize(Application application) must be called prior to any API calls into the VMAX SDK. This should be called within the onCreate method of your Application subclass. Calling this method anywhere else is not supported.

Minimum sdk version required for Millennial Media is 16, it can’t be below that.

In Millennial Media

In your Millennial Media account create an app and note its App Tracking ID. Read more.

Further Integration

Step 1: Create a package com.vmax.android.ads.mediation.partners in your app and add the files MillennialMediaInterstitial.java and MillennialMediaBanner.java from the SDK folder Mediation Files\Mediation Adapters\com\vmax\android\ads\mediation\partners to it.

Step 2: For Android Studio add MMv6.3.1.aar from the SDK folder Mediation Files\Mediation Libraries as a Module Dependency in your app

and for Eclipse add the MM folder from Eclipse\Mediation Libraries to your Eclipse Project.

Additionally you have to add Google Mobile Ads and Android Support v4 library

Add Following meta tag for google mobile ads:
 Step 3: Add the accompanying code inside the <application> tag in AndroidManifest.xml
Step 4: Add the following permissions to AndroidManifest.xml
Step 5: [Optional] If you are running ProGuard on your Android application, ensure that the following directive is added in your ProGuard configuration file proguard-rules.pro:

What would you like to do next?